Fiori Embeded i SSO

Jeśli programujesz, administrujesz, integrujesz i masz wątpliwość lub obawę, to właśnie najlepsze miejsce dla Ciebie. Pisz śmiało...
pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Fiori Embeded i SSO

Post autor: pabi » pn lip 29, 2019 2:56 pm

Witam
Mam SAP S4 Abap serwer aplikacyjny ERP. Na nim jest embeded Fiori, czyli na tym samym serwerze ERP zainstalowane zagnieżdżone Fiori (jest addon SAP Fiori Frontend Serwer 4).
Uruchomiłem SSO dla ERPa, działa przez SAP Gui i jest ok, loguje po SSO.
Próbuję się logować przeglądarką na Fiori i niestety przez przeglądarkę wymaga loginu i hasła, to SSO z serwera abapowego ERPa nie działa.
Czy ktoś może mi coś podpowiedzieć jak to działa, czy Fiori Embedded to tylko addon (wtedy to SSO uruchomione na abapie powinno działa tez na portalu bez dodatkowej konfiguracji?), czy wymaga oddzielnej konfiguracji SSO ?
Wcześniej portal to był oddzielny serwer aplikacyjny JAVA stack, a jak jest w przypadku embedded ?

endoex
Posty: 32
Rejestracja: sob gru 08, 2018 10:16 am
Lokalizacja: Warszawa
Has thanked: 7 times
Been thanked: 7 times

Re: Fiori Embeded i SSO

Post autor: endoex » wt lip 30, 2019 7:49 am

Uruchom /iwfnd/Traces i sprawdz jakie bledy sie generuja .

Moze jakas usluga nie jest aktywowana albo problem z RFC ?

https://answers.sap.com/questions/12469 ... cture.html

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 10:18 am

W logu nie ma żadnego błędu, jak podam nazwę użytkownika i hasło to loguje się poprawnie.
Co do połączeń to jest ten sam serwer, Fiori Server to tutaj tylko addon zainstalowany na Abapowym serwerze ERPa.

Czy połaczenie przez http/https idzie przez gatewaya czy ICMa , przez gatewaya tylko RFC TCP/IP ?
Ostatnio zmieniony wt lip 30, 2019 10:30 am przez pabi, łącznie zmieniany 1 raz.

bjarkowski
Posty: 101
Rejestracja: pt lip 15, 2016 5:31 pm
Has thanked: 2 times
Been thanked: 38 times

Re: Fiori Embeded i SSO

Post autor: bjarkowski » wt lip 30, 2019 10:26 am

Jakiego SSO uzywasz? SAML czy SPNego?
Czy SSO dziala dla WebGUI?

Pozdrawiam
Bartosz

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 10:35 am

A gdzie to sprawdzić ?
Na stacji wgrałem Secure Login Client 3, po stronie serwera aplikacyjnego abap zrobiłem konfigurację SSO using SNC Kerberos i po gui poszło :).
Więcej nic nie robiłem, myślałem, że to wszystko :).
SPNego wg mnie.
Ostatnio zmieniony wt lip 30, 2019 10:39 am przez pabi, łącznie zmieniany 1 raz.

bjarkowski
Posty: 101
Rejestracja: pt lip 15, 2016 5:31 pm
Has thanked: 2 times
Been thanked: 38 times

Re: Fiori Embeded i SSO

Post autor: bjarkowski » wt lip 30, 2019 10:37 am

OK, czyli Kerberos!

Sprawdz czy zadziala dla WebGUI:
https://<hostname>/sap/bc/gui/sap/its/webgui

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 10:40 am

otwarło okno logowania i czeka na wpisanie loginu i hasła

bjarkowski
Posty: 101
Rejestracja: pt lip 15, 2016 5:31 pm
Has thanked: 2 times
Been thanked: 38 times

Re: Fiori Embeded i SSO

Post autor: bjarkowski » wt lip 30, 2019 10:42 am

A na jakiej przegladarce testujesz? Sprawdz na IE

endoex
Posty: 32
Rejestracja: sob gru 08, 2018 10:16 am
Lokalizacja: Warszawa
Has thanked: 7 times
Been thanked: 7 times

Re: Fiori Embeded i SSO

Post autor: endoex » wt lip 30, 2019 10:43 am

pabi pisze:
wt lip 30, 2019 10:18 am
W logu nie ma żadnego błędu, jak podam nazwę użytkownika i hasło to loguje się poprawnie.
Co do połączeń to jest ten sam serwer, Fiori Server to tutaj tylko addon zainstalowany na Abapowym serwerze ERPa.

Czy połaczenie przez http/https idzie przez gatewaya czy ICMa , przez gatewaya tylko RFC TCP/IP ?
Polaczenie przez GTWY na RFC ABAP tyle ze nie trusted.

endoex
Posty: 32
Rejestracja: sob gru 08, 2018 10:16 am
Lokalizacja: Warszawa
Has thanked: 7 times
Been thanked: 7 times

Re: Fiori Embeded i SSO

Post autor: endoex » wt lip 30, 2019 10:56 am

GTWY50.jpg
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 11:14 am

Na IE to samo, pyta o login i hasło

endoex
Posty: 32
Rejestracja: sob gru 08, 2018 10:16 am
Lokalizacja: Warszawa
Has thanked: 7 times
Been thanked: 7 times

Re: Fiori Embeded i SSO

Post autor: endoex » wt lip 30, 2019 11:24 am

Jesli config poprawny to sprawdz authoryzacje na uzytkowniku

https://blogs.sap.com/2014/06/09/fiori- ... -from-a-z/

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 11:33 am

user na czas testów ma sap_all więc to nie kwestia uprawnień.

endoex
Posty: 32
Rejestracja: sob gru 08, 2018 10:16 am
Lokalizacja: Warszawa
Has thanked: 7 times
Been thanked: 7 times

Re: Fiori Embeded i SSO

Post autor: endoex » wt lip 30, 2019 11:40 am

pabi pisze:
wt lip 30, 2019 11:33 am
user na czas testów ma sap_all więc to nie kwestia uprawnień.
Nie jestem pewiem czy s_all tez obejmuje FIORI . Dodaj jedna role z FIORI do uzytkownika i uruchom z jego podgladu .

pabi
Posty: 189
Rejestracja: śr sty 25, 2012 2:25 pm
Has thanked: 31 times
Been thanked: 5 times

Re: Fiori Embeded i SSO

Post autor: pabi » wt lip 30, 2019 12:08 pm

Po dodaniu autoryzacji sytuacja bez zmian, logowanie do https://<host>/sap/bc/gui/sap/its/webgui nadal wymaga loginu i hasła.